Jetbrains Rider:缺少.NET Framework 4.5.2

前提:由于我们是应用程序的开发者,所以我们要下载的是SDK或者Developer Pack;而不是Runtime包(runtime是给应用程序的用户使用的)。
图片[1]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客
前提2:SDK安装完毕后,Rider的反应可能并不那么及时。建议在安装SDK前就关闭Rider哦。

这是因为我们没有安装该.NET FrameWork开发版本的SDK。解决方案如下:

确定你缺哪个版本,然后到微软官网去下载。 记得选择开发版,我这儿缺的是4.5.2; 所以我选了4.5.2 developer pack.
图片[2]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客
下载好之后,就是安装了:直接点击下一步就好;安装完毕这个.NET FrameWork 4.5.1安装到哪儿了: 图片[3]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客 再次打开Rider中,右击项目名--选择Bulid Selected Projects,就ok了。 图片[4]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客 如果编译成功了,但是Rider中的项目还是会一堆波浪线?没关系,重启Rider就好了。

这是因为我们没有装.NET Core x.x的SDK。解决方案如下:

确定你缺哪个版本(不知道就下最新版吧),然后到微软官网下载SDK 拿.net core 3.1为例,选择SDK进行下载: 图片[5]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客 双击下载完成后的exe,安装完成;(题外话如果你想用:VSCode或者PowerShell等工具来玩.net core项目,那么最好配置一下环境变量,如果不想配置也可以哦。) 配置一下环境变量 图片[6]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客 测试:在cmd窗口中输入:dotnet 回车 图片[7]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客 测试:在powershell窗口中,使用 dotnet new console -o testnetcore 命令创建一个.net core框架的控制台项目 图片[8]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客 打开Rider,选择左上角的File-→ Settings(快捷键 CTRL+ALT+S);此时你的Rider应该已经感知到.net core sdk的存在了(如若没有那么请按下图指示选择你的dotnet的安装位置) 图片[9]-Jetbrains Rider:缺少.NET Framework 4.5.2-北冥博客 以上便是对.NET开发环境缺少SDK问题的解决办法的总结,记录下来以便以后查阅。
© 版权声明
THE END
喜欢就支持一下吧
点赞13赞赏 分享
评论 抢沙发

请登录后发表评论